Inclement Weather
Incident Report for Flash
Resolved
The severe weather in central Texas has passed and electrical service has been restored to the majority Austin Texas consumers. We are working as quickly as possible to eliminate the backlog of Support requests and return to normal operations. We greatly appreciate the well wishes, patience, and understanding from our customers through the previous difficult week!
Posted Feb 22, 2021 - 11:32 CST
Identified
We have created this incident to let our customers know that Texas is experiencing a severe winter storm which is causing intermittent electrical outages across the state, affecting more than 200 thousand households.

You may experience a delay in response time when reaching out to our FlashParking Support team, who are based in Austin Texas, over the next 48 hours. We are working as quickly as possible to address all incoming requests.
Posted Feb 15, 2021 - 12:07 CST
This incident affected: FlashValet and FlashPARCS.