Service Degradation for FlashParcs & FlashValet

Incident Report for Flash

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 15:23 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 23, 2026 - 14:41 CST

Update

We are continuing to work on a fix for this issue.
Posted Jan 23, 2026 - 13:40 CST

Identified

We are currently operating in offline mode and are in the process of gradually restoring full system functionality.

Earlier today, a maintenance command intended for a limited number of kiosks was inadvertently applied across the broader organization. The surge in activity, resulted in failed requests and degraded system performance. To stabilize the environment, kiosks switched into hybrid mode. The system is now stabilizing and we are carefully bringing services back online in a controlled manner.

If you have any immediate operational concerns, please contact our Support team
Posted Jan 23, 2026 - 13:25 CST

Update

We are continuing to investigate this issue.
Posted Jan 23, 2026 - 13:11 CST

Investigating

Our team is currently investigating potential issues affecting FlashParcs and Flash Valet. We will update the status when the issue has been identified.
Posted Jan 23, 2026 - 12:11 CST
This incident affected: FLASH Products (FlashValet, FlashPARCS).