Phone Support Provider Degraded Performance
Incident Report for Flash
Resolved
Our provider is reporting that this incident has been resolved and we are observing calls being connected with Support technicians again.
Posted Aug 25, 2022 - 11:39 CDT
Investigating
Our virtual call center provider is experiencing degraded performance, preventing calls from being connected to a Support technician. We are monitoring the issue, and will provide an update as soon as our provider has resolved the issue.
Posted Aug 25, 2022 - 11:09 CDT
This incident affected: FlashValet, FlashPARCS, and FlashAR.