Phone Support Provider Degraded Performance
Incident Report for Flash
Resolved
All phone provider issues have been resolved.
Posted Mar 22, 2022 - 12:39 CDT
Investigating
Our phone provider is currently experiencing issues delivering calls to our Support team members. Calls to our Support team may not be delivered as expected or end abruptly. We are monitoring updates to our provider's status and will provide communication once this issue has been resolved.

This issue is not affecting the Flash Parking product platform.
Posted Mar 22, 2022 - 11:36 CDT
This incident affected: FlashValet and FlashPARCS.