Credit Card Processing Service Disruption - First Data North
Incident Report for Flash
Resolved
Credit card processing on the First Data North platform continues to remain stable for FlashPARCS and FlashValet products, and this incident has been resolved.
Posted Feb 03, 2024 - 18:41 CST
Monitoring
We are observing successful transaction processing at locations using the First Data North for credit card processing. FlashParking will continue to monitor for updates from the payment processor.
Posted Feb 03, 2024 - 15:58 CST
Investigating
We are investigating reports that the payment processor First Data North is experiencing some delays or failures when trying to process transactions with FlashValet or FlashPARCS. FlashParking will monitor for further updates.

This issue only affects those merchants processing credit cards through First Data North.
Posted Feb 03, 2024 - 14:31 CST
This incident affected: FlashValet and FlashPARCS.