Phone Support Provider Degraded Performance
Incident Report for Flash
Resolved
Our virtual call center provider has reported that this is resolved. We are now seeing calls connect to Support technicians as expected.
Posted Mar 28, 2023 - 17:09 CDT
Investigating
Our virtual call center provider is experiencing degraded performance, preventing some calls from being connected to a Support technician. We are monitoring the issue, and will provide an update as soon as our provider has resolved the issue.

Please email our Support team at support@flashparking.com if you are unable to connect to a technician.

This issue does not impact performance of any products.
Posted Mar 28, 2023 - 12:54 CDT
This incident affected: FlashValet, FlashPARCS, and FlashAR.