Our virtual call center provider is reporting that mitigation options are available and they are not expecting a recurrence. Calls are being handled as expected.
Posted Oct 08, 2024 - 17:54 CDT
Monitoring
Our virtual call center provider has not observed issues for the past 30 minutes. They have a potential mitigation ready in case they observe a recurrence. We will continue to monitor for issues.
Posted Oct 08, 2024 - 17:06 CDT
Investigating
Our virtual call center provider is experiencing degraded performance, preventing some calls from being connected to a Support technician. We are monitoring the issue, and will provide an update as soon as our provider has resolved the issue.