We worked with our services provider to resolve reporting delays. All reporting processes should be working as expected at this time. We will continue to monitor for issues.
Posted May 06, 2025 - 10:54 CDT
Investigating
Our team is currently investigating performance issues with reporting requests in the Flash Admin Portal. We are working with our service providers to investigate and resolve observed issues. During this time report processing may be delayed. There is no impact to onsite processing of transactions.
Posted May 05, 2025 - 10:53 CDT
This incident affected: FLASH Products (Reporting).