Performance Degradation Flash Valet & Admin Portal
Incident Report for Flash
Resolved
This incident has been resolved.
Posted May 20, 2024 - 18:45 CDT
Update
FlashValet and Admin Portal have returned to normal functionality. We will continue to monitor throughout the evening.
Posted May 20, 2024 - 17:39 CDT
Update
We are continuing to investigate this issue.
Posted May 20, 2024 - 16:55 CDT
Update
We are continuing to investigate this issue.
Posted May 20, 2024 - 16:44 CDT
Investigating
We are currently investigating reports of the system responding slowly.
Posted May 20, 2024 - 16:44 CDT
This incident affected: FLASH Products (FlashValet, Admin Portal).