Credit Card Processing Service Disruption - Windcave
Incident Report for Flash
Resolved
We have been informed by Windcave of a temporary issue between Windcave and the merchant provider Fiserv / FirstData, which has already been resolved.
Posted Sep 25, 2024 - 17:11 CDT
Investigating
We have been informed by our payment processing partner Windcave that they are investigating an issue where customers are experiencing some delays or failures when trying to process transactions. FlashParking will monitor our payment processing partner for further updates.

This will impact FlashPARCS locations with EMV products utilizing the Windcave payment gateway.

It will not affect locations utilizing FlashValet products, or FlashPARCS products utilizing the USAePay payment gateway.

Additional updates can also be obtained at https://status.windcave.com/
Posted Sep 25, 2024 - 16:39 CDT
This incident affected: FLASH Products (FlashPARCS).