Credit Card Processing Service Disruption - Windcave
Incident Report for Flash
Resolved
Our payment processing partner Windcave has informed us that all services are operating and the issue has been resolved.
Posted Feb 15, 2023 - 20:09 CST
Investigating
We have been informed by our payment processing partner Windcave that they are investigating an issue where customers are experiencing some delays or failures when trying to process transactions. FlashParking will monitor our payment processing partner for further updates. This will affect FlashPARCS locations with EMV products, but will not affect locations utilizing FlashValet products.

Additional updates can also be obtained at https://status.windcave.com/
Posted Feb 15, 2023 - 19:07 CST
This incident affected: FlashPARCS.